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ВВЕДЕНИЕ 

 

Настоящий курс лабораторных работ направлен на 

изучение и освоение принципов создания виртуальных 

средств, моделирующих работу процессора вычислительного 

устройства. 

Программная система LabView является удобным 

средством для проектирования измерительных каналов, 

приборов, систем. Она обеспечивает построение и 

моделирование измерительных структур различной 

сложности. Система имеет библиотеку виртуальных модулей 

(моделей) измерительных средств, их отдельных блоков и 

компонентов. Она позволяет пользователю создавать 

виртуальные измерительные приборы любой сложности и 

формировать свою библиотеку виртуальных средств (VI). 

Система обладает удобными средствами редактирования и 

отладки и обеспечивает работу с реальными измерительными 

приборами, модулями и сигналами. 

Создание виртуального измерительного средства 

связано с определением его измерительной функции, 

созданием лицевой панели с органами управления и 

средствами представления данных, созданием структурной 

схемы, выполняющей заданную измерительную функцию, 

редактированием и отладкой работы измерительного 

устройства. Для этого система поддерживает 

соответствующие режимы: создание лицевой панели 

измерительного прибора  Panel, создание структурной схемы 

и отладка работы  Diagram. 

Каждый режим имеет свое окно, панель управления и 

поддерживается библиотекой (палитрой) моделей 

функциональных блоков (виртуальных модулей). 
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Лабораторная работа № 1 

 

Знакомство с LabVIEW 

 

Цель работы: 

Получение основных сведений о программно-

инструментальной средеLabVIEW.  

Задачи работы: 

 Создание простейших виртуальных приборов 

(VI). 

 Моделирование простейших вычислительных 

алгоритмов. 

 Структура виртуального прибора LabVIEW 

  Отчет: 

- титульный лист; 

 цели и задачи лабораторной работы; 

 задание на лабораторную работу; 

 результаты выполненной работы. 

 

Справочно-методический материал. Файл LabVIEW – 

виртуальный инструмент – состоит из двух панелей. Одна из 

них имитирует переднюю панель реального физического 

прибора, (рисунок 1), на второй панели (рисунок 2) строится 

блок-схема виртуального инструмента на языке G. 

Обычно при запуске LabVIEW на экране появляются 

обе панели, расположенные каскадом. Одновременное 

нажатие клавиш [Ctrl+T] позволяет упорядочить 

расположение панелей: слева – передняя, справа – блок-

схема. В строке заголовка блок-схемы к имени текущего 

файла добавляется слово «Diagram», что позволяет отличить 

эту панель от передней. Под этими именами обе панели 

представлены на панели задач как два самостоятельных окна. 

 

 



5 

 

 

 
Рис. 1. Передняя панель реального физического прибора 

 
 

Рис. 2. Блок-схема виртуального инструмента на языке G 
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Цифрами на рисунках обозначены: 

1. Панель инструментов (Toolbar), 2. Ярлык (Label) 3. 

Цифровойрегулятор (Numeric Control), 4. Ярлык (Label) , 5. 

Терминалцифровогорегулятора (Numeric Control Terminal), 6. 

Терминалручки (Knob Terminal), 7. Численнаяконстанта( 

Numeric Constant), 8. Функцияумножения (Multiply Function), 

9. Пиктограмма (Icon), 10. Ручка (Knob Control), 11. 

Описаниеграфика (Plot Legend), 12. График (XY Graph), 13. 

Соединение, нитьданных (Wire Data Path), 14. 

Терминалграфика (XY Graph Terminal), 15. 

Функцияобъединениявкластер (Bundle Function), 

16.Подпрограмма, сабви (SubVI), 17. Цикл for (For Loop 

Structure) 

Работа с главным меню LabVIEW Ниже имени файла 

расположено главное меню панелей, состоящее из 

пунктов: File, Edit, Operate, Project, Windows, Help. Ниже 

располагается панель управляющих клавиш. Рассмотрим 

некоторые команды: 

File → Close – закрыть файл. Выбор этой опции с 

передней панели позволяет закрыть файл виртуального 

инструмента в целом, а выбор этой же опции на панели блок-

схемы убирает только одну панель блок-схемы. 

Edit→ Remove Bad Wires – удалить ошибочные 

соединения проводов  

Operate → Run – запуск программы. 

Operate → Make Current Values Default – сделать 

текущие величины (источников, приемников) значениями по 

умолчанию. Опция позволяет сохранять численные значения, 

установленные пользователем, до следующего вызова 

программы. Если пользователь не выбрал эту опцию до 

сохранения файла, то при следующем вызове этого файла 

значения источников и приемников будут нулевыми. 

Windows → Show Diagram – показать блок-схему 

(находится на передней панели). 



7 

 

Windows → Show Panel – показать переднюю панель 

(находится на панели блок-схемы). 

Windows → Show Controls Palette – показать набор 

управляющих элементов Controls передней панели. 

Windows → Show Functions Palette – показать набор 

функций Functions (находится на панели блок-схемы). 

Windows → Show Tools Palette – показать набор 

инструментов Tools (опция присутствует на обеих панелях). 

Windows → Tile Left and Right; Windows → Tile Up and 

Down – эти опции позволяют располагать панели справа и 

слева, сверху и снизу соответственно. 

Help → Show Help – вызов окна помощи. Используйте 

эту опцию для вызова описания виртуального инструмента, 

функции или определения типа провода, а также для 

определения названия выводов виртуального инструмента. 

Для этого помещайте конец провода «катушки» на тот вывод 

инструмента, название которого необходимо узнать, при этом 

будут мигать изображения обоих выводов – на блок-схеме и в 

окне помощи. 

Help → Online Reference – вызов справочной системы 

LabVIEW. 

Управляющие клавиши 

Клавиша «Run» («Пуск») располагается в левом 

верхнем углу обеих панелей. После «нажатия» этой клавиши 

происходит запуск программы. Остановка выполнения 

программы должна быть предусмотрена самой программой. 

На этапе сборки блок-схемы или при наличии в ней ошибок 

изображение стрелки на клавише разделено на две части. 

Если «нажать» на клавишу при таком виде стрелки, на экран 

будет выведен список ошибок (Error List). Список ошибок 

позволяет найти место каждой ошибки. Для этого выделяют 

строку с интересующей ошибкой, нажимают кнопку «Find». 

Место ошибки будет выделено программой. 

Клавиша «Run Continiously» («Циклический режим») – 

запуск программы в режиме цикла. Выполнение можно 
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приостановить клавишей «Pause» («Пауза»). 

Клавиша «Abort Execution» («Стоп») – остановка 

программы. Клавиши, присутствующие только на панели 

блок-схемы: 

- клавиша «Highlight Execution» («Лампочка») - 

используется для наблюдения прохождения данных по 

проводам в замедленном и пошаговом режимах. Передача 

данных от элемента к элементу схемы изображается 

мультипликацией; 

- остальные три клавиши используются для 

пошагового выполнения программы. 

Наборы инструментов 

Набор инструментов Tools (Show Tools 

Palette) позволяет изменить вид и позиции курсора. Основные 

позиции (рисунок 1): 

- «стрелка» – перемещение, выделение и изменение 

размеров объектов; 

- «катушка» – соединение объектов блок-схемы 

проводами. 

- Активный элемент – конец провода; 

- «А» – печать текста с клавиатуры, ввод числовых 

данных в окна источников и метки объектов; 

- «кисть» – раскрашивание объектов и фона. Этот вид 

курсора не используется для вызова всплывающего меню 

объектов правой кнопки мыши; 

- «рука» – изменяет позиции выключателя и тем самым 

управляет цифровыми источниками (нажимая на клавиши 

«больше»или «меньше»), виртуальными осциллографами 

(нажимая на переключатели и кнопки управления ими) и 

другими объектами. Также используется для ввода числовых 

данных. 

Набор управляющих элементов Controls передней 

панели (Show Controls Palette) позволяет вывести на левую 

панель контрольно-измерительные приборы, виртуальные 

осциллографы, кнопки. При помещении курсора на окно 
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набора в верхней части окна высвечивается название 

соответствующего поднабора (рисунок1) (например, 

«Numeric» – «Цифровые приборы»). Поднабор открывается 

нажатием левой кнопки мыши. 

Перемещая курсор по элементам поднабора, можно 

узнать название прибора. Элемент выделяется квадратной 

рамкой, его название отображается вверху поднабора. 

Набор инструментов Functions панели блок-схемы 

(Show Functions Palette) содержит функции и виртуальные 

инструменты (VI), используемые для построения блок-схемы 

(рисунок 2). Из набора Functions вызываются: управляющие 

структуры (циклы While, For), формульный узел (Formula 

Node) –Structures поднабор; преобразователи строк –

 String поднабор; приборы преобразования Фурье и линейной 

алгебры – Analysis поднабор и многие другие. 

Название функции или виртуального инструмента 

определяется аналогично набору Controls. 

Наборы Controls и Functions можно вывести, щелкнув правой 

кнопкой мыши в любом месте передней панели и панели 

блок-схемы соответственно. 

Элементы в LabVIEW имеют один или несколько 

выводов (терминалов). Схему терминалов позволяет 

рассмотреть опция Show>>Terminals выпадающего меню 

объекта на панели блок-схемы. 

Все приборы передней панели имеют один вывод, 

большинство элементов панели блок-схемы (из 

набора Functions) – несколько. Вывод объекта, принимающий 

данные, будем называть входом. Вывод, который передает 

данные другим элементам, назовем выходом. Если объект 

только передает данные, то его называют источником. Его 

вывод является выходом. Объект, который только принимает 

данные – приемник. Вывод этого объекта – вход. Термины 

«источник» –«выход», «приемник» – «вход» однозначно 

соответствуют друг другу. Выходы элементов панели блок-

схемы выделяются утолщенной линией. В любом канале 
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передачи данных все подключенные к каналу выводы 

объектов должны быть согласованы: 

1) по типу выводов; 

2) по типу передаваемых и принимаемых данных. 

К каналу связи должен быть подключен только один 

источник, к одному источнику данных можно подключить 

неограниченное число приемников. Соединение только одних 

приемников (или источников) признается программой 

ошибочным. 

Для выделения проводов выбрать пиктограмму с 

изображением стрелки. Установите стрелочный указатель на 

участок провода, который необходимо удалить. Нажатием 

левую кнопку мыши один раз выделяется один сегмент, 

двойным щелчком выделяется ветвь от узла до элемента, 

тройным – все разветвленное соединение. 

Типы и проводники данных. Создание подпрограмм 

ВП. В среде LabVIEW проводники данных используются для 

соединения многочисленных терминалов данных. Поля 

ввода/вывода должны быть совместимыми с типами данных, 

передаваемыми им по проводникам. 

Например, нельзя соединять поле вывода массива с 

полем ввода данных численного типа. Кроме того, характер 

соединения должен быть корректным. Проводники должны 

быть подсоединены лишь к одному источнику данных и, по 

крайней мере, к одному полю ввода данных. 

Например, нельзя соединять 2 элемента отображения. 

Компонентами, определяющими совместимость соединения, 

являются тип данных элемента управления и/или 

отображения и тип данных поля ввода/вывода. 

Типы данных. В данном курсе используются 

следующие типы данных: 

Numeric (численный тип) 

- Floating point — число с плавающей запятой, 

отображается в виде оранжевых терминалов. Может быть 

представлено в виде single (32 bit), double (64-bit) или extended 
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(128-bit) precision (с одиночной, двойной или расширенной 

точностью). Число с плавающей запятой может быть 

комплексным. 

- Integer — целочисленный тип, отображается в виде 

голубых терминалов. Возможны три представления целых 

чисел: 8, 16 и 32 бита. Один бит может использоваться для 

знака числа, если это число является знаковым целым. 

Boolean — логический тип, отображается в виде 

зеленых терминалов. Логический тип может принимать 

только два значения: 0 (FALSE) или 1 (TRUE). 

String — строковый тип, отображается в виде розовых 

терминалов. Строковый тип данных содержит текст в ASCII 

формате. 

Path — путь к файлу, отображается в виде терминалов. 

Путь к файлу близок строковому типу, однако, LabVIEW 

форматирует его, используя стандартный синтаксис для 

используемой платформы. 

Array — массивы включают типы данных 

составляющих элементов и принимают соответствующий им 

цвет. 

Проводники данных 

Данные между объектами блок-диаграммы передаются 

по соединительным линиям – проводникам данных. 

Проводник данных аналогичен переменным в текстовых 

языках программирования. 

Каждый проводник данных имеет единственный 

источник данных, но может передавать их ко многим ВП и 

функциям. Проводники данных различаются цветом, стилем и 

толщиной линии, в зависимости от типа передаваемых 

данных. 

Автоматическое соединение объектов проводниками 

данных 

В среде LabVIEW объекты соединяются проводниками 

данных после их помещения на блок-диаграмму. В 

автоматическом режиме среда LabVIEW подключает те поля 
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ввода/вывода данных, которые наиболее совместимы, 

несовместимые поля остаются несоединенными. 

Если выбранный объект помещается на блок-

диаграмме недалеко от другого объекта, среда LabVIEW 

показывает пунктирные временные проводники данных, 

намечающие области возможного соединения. Следует 

обратить внимание, что при отпускании кнопки мыши 

LabVIEW автоматически подключает проводник данных к 

полю ввода/вывода данных, выбранного объекта. 

Корректировка параметров автоматического 

подключения проводников осуществляется через пункты 

главного меню Tools>>Options>>Block Diagram. 

Пример созданрия виртуального прибора 

Преобразование °C в °F 

Ниже приведена последовательность действий для 

создания ВП, который будет преобразовывать значение 

температуры из градусов Цельсия в градусы Фаренгейта. 

Лицевая панель 

1. Выберите пункт главного меню File»New»VI, чтобы 

открыть новую лицевую панель. 

 

 
 

Рис.3. Лицевая панель ВП Преобразование 

температуры 

 

2. (Дополнительно) Выбрать пункт главного меню 

Window»Tile Left and Right для вывода на экран рядом друг с 

другом лицевой панели и блок-диаграммы. 

3. Создайте цифровой элемент управления. Он будет 

использован для ввода значений температуры в °С. 

a. Выберите цифровой элемент управления в разделе 
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палитры Элементов в подразделе Controls»Numeric (Числовые 

элементы). Для вывода на экран палитры Controls 

(Элементов) следует щелкнуть правой кнопкой мыши по 

рабочему пространству лицевой панели. 

b. Поместите цифровой элемент управления на 

лицевую панель.  

c. В поле собственной метки элемента управления 

напечатайте «Град С» и щелкните мышью в свободном 

пространстве лицевой панели или нажмите кнопку Enter, 

показанную слева, на инструментальной панели. Если сразу 

после создания элемента не присвоить имя его собственной 

метке, то LabVIEW присвоит имя, заданное по умолчанию. 

Собственная метка в любое время доступна для 

редактирования, оно производится с помощью инструмента 

ВВОД ТЕКСТА, показанного слева. 

4. Создайте цифровой элемент отображения данных. 

Он будет использован для отображения значений 

температуры в °F. 

5. Выберите цифровой элемент отображения в палитре 

Элементов в подразделе Controls»Numeric (Числовые 

элементы). 

6. Поместите элемент отображения данных на лицевую 

панель. 

7. В поле собственной метки элемента управления 

напечатайте «Град F» и щелкните мышью в свободном 

пространстве лицевой панели или нажмите кнопку Enter. 

На блок-диаграмме LabVIEW создаст терминалы 

данных, соответствующие элементам управления и 

отображения. Терминалы данных представляют тип данных 

соответствующих элементов. Например, терминал данных 

DBL, показанный слева, представляет тип числовых данных 

двойной точности с плавающей запятой. 

Блок-диаграмма 

8. Перейдите на блок-диаграмму, выбрав пункты 

главного меню Window» Show Diagram. 



14 

 

 
Рис.4. Блок-диаграмма ВП «Преобразование 

температуры» 

 

9. Выберите функцию Multiply (Умножение) из 

палитры Функций в разделе Functions»Numeric 

(Арифметические функции). Поместите ее на блок-

диаграмму. Для вывода на экран палитры Functions 

(Функций) следует щелкнуть правой кнопкой мыши в 

рабочем пространстве блок-диаграммы. 

10. Выберите функцию Add (Сложение) из палитры 

Функций в разделе Functions»Numeric (Арифметические 

функции). Поместите ее на блок-диаграмму. 

11. Выберите числовую константу из палитры 

Функций в разделе Functions»Numeric (Арифметические 

функции). Поместите две числовые константы на блок-

диаграмму. После размещения числовой константы на блок-

диаграмме поле ввода ее значений подсвечивается и готово 

для редактирования. Одной константе присвойте значение 1,8 

, другой 32,0. Если значение в константу не введено сразу 

после ее размещения на блок-диаграмме, следует 

использовать инструмент ВВОД ТЕКСТА. 

12. Перейдите на лицевую панель, выбрав в главном 

меню пункт Window»Show Panel. 

13. Сохраните ВП, он будет использоваться позднее. 

a. Выберите пункт главного меню File»Save. 

b. Укажитекаталог c:\exercises\LV Basics I. 

c. В диалоговом окне введите ^ Преобразование С в F 

(начало).vi 

d. Нажмите кнопку Save. 
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Запуск В 

Создание подпрограмм ВП 

После того как ВП сформирован, создана его иконка и 

настроена соединительная панель, виртуальный прибор 

можно использовать как подпрограмму в других ВП.  

Виртуальный прибор, используемый внутри другого 

виртуального прибора, называется подпрограммой ВП. 

Подпрограмма ВП соответствует подпрограмме в 

текстовых языках программирования. Узел подпрограммы ВП 

соответствует вызову подпрограммы в текстовых языках 

программирования.  

Узел – это графическое представление подпрограммы 

ВП, а не собственно исполняемый код подпрограммы ВП, так 

же как вызов подпрограммы в текстовых языках 

программирования не есть сам исполняемый код 

подпрограммы.  

Использование подпрограмм ВП помогает быстро 

управлять изменениями и отладкой блок-диаграмм. Для 

демонстрации аналогии между подпрограммой ВП и 

подпрограммой текстовых языков программирования ниже 

представлены текстовый аналог кода и блок-диаграмма: 

 

 Аналоги программного кода и блок-диаграмм 

Исходный текст Вызов подпрограммы 

function average (in1,in2,out) 

{out = (in1 + in2) / 2.0;} 

main 

{ave-

age(point1,point2,pointavg);} 
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Создание иконки ВП и настройка соединительной 

панели. Следующий шаг после создания блок-диаграммы и 

формирования лицевой панели ВП – создание иконки ВП и 

настройка соединительной панели для использования 

виртуального прибора в качестве подпрограммы ВП. 

Создание иконки ВП 

Каждый виртуальный прибор в правом верхнем 

углу лицевой панели и в окне блок-диаграммы отображает 

иконку, показанную слева. Иконка – графическое 

представление прибора. Она может содержать текст, рисунок 

или и то и другое одновременно. 

Если ВП используется в качестве подпрограммы, то 

иконка идентифицирует его на блок-диаграмме другого ВП. 

Установленная по умолчанию иконка ВП содержит 

номер, который указывает, сколько новых приборов 

открылось после запуска LabVIEW. 

Создать собственную иконку, отличную от заданной 

по умолчанию, можно, щелкнув правой кнопкой мыши по 

иконке в правом верхнем углу лицевой панели или блок-

диаграммы. 

Затем выбрать пункт Edit Icon (Редактирование 

иконки) из контекстного меню. Icon Editor (Редактор иконки) 

можно также вызвать двойным щелчком левой кнопки мыши 

в верхнем правом углу одной из панелей. Редактирование 

иконки доступно также из пункта главного меню File, далее 

VI Properties (Свойства ВП), где в диалоговом окне Category 

(Категория) следует выбрать пункт General (Общие) и нажать 

кнопку Edit Icon (Редактирование иконки). 

Проектирование иконки выполняется в области 

редактирования, расположенной в центре окна ^ Icon 

Editor (Редактора иконки), при помощи инструментов, 

расположенных слева от области редактирования. Вид иконки 

и доступный на блок-диаграмме и в правом верхнем углу 
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обеих панелей размер иконки появляется справа от области 

редактирования, в соответствующем поле, как показано ниже. 

 

 
Рис.5. Создание иконки 

 

В зависимости от типа монитора, иконка может быть 

создана для черно-белого, 16-цветного или 256-цветного 

режима. Для печати, в случае отсутствия цветного принтера, 

LabVIEW использует черно-белую иконку. По умолчанию 

установлен 256-цветный режим. 

Меню Edit (редактирование) используется для 

вырезания, копирования и вставки картинок из иконки или в 

нее. При выборе фрагмента иконки для вставки картинки 

LabVIEW изменяет размер картинки для соответствия 

размеру выбранной области. 

32 точки.Предусмотрена возможность перемещения 

графических символов из файловой системы в верхний 

правый угол лицевой панели или блок-диаграммы. LabVIEW 

автоматически преобразует изображение в иконку размером 

32 

Для копирования цветной иконки в черно-белую (или 

наоборот) достаточно выбрать опцию Copy from, 
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находящуюся в правой части диалогового окна Icon 

Editor. Нажать кнопку OK для окончательной замены 

Настройка соединительной панели 

Для использования ВП в качестве 

подпрограммы ВП необходимо настроить соединительную 

панель, показанную слева. 

Соединительная панель является совокупностью полей 

ввода/вывода данных, соответствующих элементам 

управления и отображения этого ВП, подобно набору 

параметров вызова функции в текстовых языках 

программирования. Соединительная панель определяет поля 

входных и выходных данных ВП. Таким образом, ВП можно 

использовать в качестве подпрограммы. 

Каждому полю ввода или вывода данных назначается 

свой элемент лицевой панели. Для редактирования 

соединительной панели необходимо щелкнуть правой 

кнопкой мыши на иконке ВП и выбрать из контекстного 

меню пункт Show Connector (Показать поля ввода/вывода 

данных). Вместо иконки появится соединительная панель, в 

которой каждый прямоугольник соответствует полю ввода 

или вывода данных. Количество отображаемых LabVIEW 

полей ввода/вывода данных соответствует количеству 

элементов на лицевой панели. Ниже показана лицевая панель, 

содержащая четыре элемента управления и один элемент 

отображения. Таким образом, в соединительной панели 

LabVIEW отображает четыре поля ввода и одно поле вывода 

данных. 

Выбор и редактирование шаблона соединительной 

панели 

Выбор шаблона осуществляется щелчком правой 

кнопки мыши на соединительной панели и выбором 

пункта Patterns (Шаблон) из контекстного меню. В шаблоне 

некоторые из полей ввода/вывода данных можно оставить без 
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соединения и задействовать позднее при необходимости. 

Такая гибкость дает возможность вносить изменения с 

минимальным отражением на иерархии ВП. Причем не все 

элементы лицевой панели должны быть обязательно 

задействованы в соединительной панели. 

 

 
 

Рис. 6. Соответствие количества полей ввода/вывода 

от количества отображаемых элементов на соединительной 

панели 

 

Задействованные поля выделены цветом, 

соответствующим типу данных элемента. Максимально 

возможное количество полей ввода/вывода данных 

ограничено 28. 

 Привязка полей ввода/вывода данных к элементам 

лицевой панели. После выбора шаблона соединительной 

панели необходимо каждому полю назначить свой элемент 

лицевой панели. Для упрощения использования 

подпрограммы ВП следует поля ввода данных размещать 

слева, а поля, связанные с элементами отображения, - справа 
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на соединительной панели. 

Чтобы назначить поля ввода или вывода данных, 

следует щелкнуть по выбранному полю левой кнопкой мыши, 

затем щелкнуть мышью на элементе, который необходимо 

связать с этим полем, после этого вывести курсор в свободное 

пространство лицевой панели и снова щелкнуть мышью. 

Задействованные поля примут цвет, определенный типом 

данных соответствующего элемента. 

Можно также сначала щелкнуть левой кнопкой мыши 

по элементу, а потом по полю ввод/вывода данных. 

ВП Преобразования °С в °F в виде подпрограммы 

Лицевая панель 

1. Выберите пункт главного меню File»Open, укажите 

папку c:\exercises\LV Basics I и выберите 

файл Преобразование C в F (начало).viЕсли закрыты все ВП, 

следует нажать кнопку Open VI (Открыть ВП) в диалоговом 

окне LabVIEW.Появится следующая лицевая панель: 

 

 
Рис. 7.  Лицевая панель ВП 

 

2. Щелкните правой кнопкой мыши по иконке ВП и в 

контекстном меню выберите пункт Edit Icon (Редактирование 

иконки). Появится диалоговое окно редактора иконки Icon 

Editor. 

3. Дважды щелкните правой кнопкой мыши по 

инструменту ВЫБОР(показан слева). 

4. Нажав кнопку , очистите область редактирования 

иконки. 

5. Дважды щелкните по инструменту 

ПРЯМОУГОЛЬНИК (показан слева), чтобы обвести область 

редактирования границей выбранного цвета. 
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6. Создайте следующую иконку: 

 

 
 

Рис. 8. Вид новой иконки ВП «Преобразование 

температуры» 

 

a. Введите текст инструментом ВВОД ТЕКСТА, 

который показан слева. 

b. Напечатайте «C» и «F». 

c. Для выбора размера шрифта дважды щелкните левой 

кнопкой мыши по инструменту ВВОД ТЕКСТА. 

d. Чтобы нарисовать стрелку, воспользуйтесь 

инструментом КАРАНДАШ. 

Внимание. Для рисования вертикальных, 

горизонтальных и диагональных линий требуется во время 

рисования нажать и удерживать клавишу . 

e. Для передвижения текста и стрелки по полю 

редактирования иконки используйте инструмент ВЫБОР и 

стрелки на клавиатуре. 

f. В разделе Copy from (Копировать) выберите B & 

W (черно-белую) иконку и 256 Colors (256-цветный режим) 

для создания черно-белой иконки, которую LabVIEW 
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использует в случае отсутствия цветного принтера. 

g. В разделе Copy from (Копировать) выберите 16 

Сolors и 256 Colors. 

h. После завершения редактирования иконки нажмите 

кнопку ^ OK и закройте Icon Editor. Новая иконка появится в 

правом верхнем углу обеих панелей. 

7. Перейдите на лицевую панель, щелкните правой 

кнопкой мыши на иконке и выберите пункт ^ Show 

Connector (Показать поля ввода/вывода данных) из 

контекстного меню. Количество отображаемых LabVIEW 

полей ввода/вывода данных соответствует количеству 

элементов на лицевой панели. Например, лицевая панель 

этого ВП имеет два элемента Град C и Град F и LabVIEW 

выводит в соединительной панели два поля, показанные 

слева. 

8. Элементам управления и отображения данных 

назначьте соответственно поля ввода и вывода данных. 

a. В пункте главного меню ^ Help (Помощь) 

выберите Show Context Help (контекстную подсказку) и 

выведите на экран окно Context Help (контекстной справки) 

для просмотра соединений. 

b. Щелкните левой кнопкой мышки на левом поле 

соединительной панели. Инструмент УПРАВЛЕНИЕ 

автоматически поменяется на инструмент СОЕДИНЕНИЕ, а 

выбранное поле окрасится в черный цвет. 

c. Щелкните левой кнопкой мыши по элементу Град C. 

Левое поле станет оранжевым и выделится маркером. 

d. Щелкните курсором по свободному пространству. 

Маркер исчезнет, и поле окрасится в цвет данных типа 

соответствующего элемента управления. 

e. Щелкните левой кнопкой мыши по правому полю 

соединительной панели и элементу Град F. Правое поле 

станет оранжевым. 

f. Щелкните курсором по свободному пространству. 

Оба поля останутся оранжевыми. 
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g. Наведите курсор на область полей ввода/вывода 

данных. Окно ^ Context Help (контекстной справки) покажет, 

что оба поля соответствуют типу данных двойной точности с 

плавающей запятой. 

9. Выберите пункт главного меню File»Save. 

Сохраните ВП под именем Преобразование C в F.vi, он будет 

использоваться позднее. 

10. Выберите пункт главного меню File»Close. 

Закройте ВП. 

Использование подпрограмм ВП 

После создания ВП, оформления его иконки и 

настройки соединительной панели ВП может использоваться 

в качестве подпрограммы. Чтобы поместить подпрограмму 

ВП на блок-диаграмму, следует выбрать на 

палитре Functions (Функций) подраздел Select a VI (Выбор 

ВП). Указать ВП и перенести его на блок-диаграмму. 

Открытый ВП можно поместить на блок-диаграмму 

другого ВП, переместив на нее иконку этого ВП с помощью 

инструмента ПЕРЕМЕЩЕНИЕ. 

 Редактирование подпрограммы ВП 

Вызов лицевой панели подпрограммы ВП из блок-

диаграммы другого ВП производится двойным щелчком на 

нем инструментом УПРАВЛЕНИЕ или ПЕРЕМЕЩЕНИЕ. Это 

же можно сделать с помощью главного меню, выбрав в 

пункте Browse (Обзор) подпункт This VI’s 

SubVIs (Подпрограммы этого ВП). Для вызова блок-

диаграммы подпрограммы ВП следует, удерживая клавишу , 

дважды щелкнуть на нем левой кнопкой мыши. 

Изменения, внесенные в подпрограмму ВП, доступны 

вызывающим его программам только после предварительного 

их сохранения. 

Варианты заданий 

1. Создать виртуальный прибор производящий 

сложение двух целых чисел с использованием панели 

функций “Mathematics → Numeric”. Обеспечить решение той 
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же задачи с использованием элемента “Formula Node”. 

Произвести отладку работы виртуального прибора в 

циклическом режиме и в режиме однократного запуска. 

2. Реализовать вычисления по формуле: z = Ax2+By3. в 

виде подпрограммы. Создать VI с возможностью задавать 

значения переменных x и y при помощи элементов «Numeric 

Control». 

3. Реализовать возможность вычисления степени 

произвольного положительного числа по формуле: : x
y
 = exp(y 

* log(x))). Обеспечить возможность задавать значения 

переменных x и y при помощи элементов «Numeric Control». 

Вычисление степени реализовать в виде SubVI. 

4. Создать виртуальный прибор, отображающий 

осциллограмму виде фигуры Лиссажу. Обеспечить 

возможность регулировки частоты исходных сигналов. 

Сохранить в файле осциллограммы для соотношения частот 

1:1, 1:2 и 1:3. 

5. Создать виртуальный прибор, имитирующий 

двухлучевой осциллограф, отображающий гармонический 

сигнал и прямоугольные импульсы одинаковой частоты. 

Обеспечить возможность регулировки скважности 

прямоугольных импульсов. 

6. Создать виртуальный прибор, отображающий 

случайный сигнал с временем выборки 1с. Обеспечить 

световую сигнализацию превышения некоторого, 

произвольно задаваемого уровня сигнала. 

7. Создать виртуальный прибор, отображающий 

гармонический сигнал с возможностью наложения шума. 

Создать элементы управления, позволяющие регулировать 

амплитуду и частоту гармонического сигнала, а также 

включение и выключение наложения шумового сигнала. 
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